Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31293 Accepted: 12643
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIANSample Output
1 3 0Source
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cmath>
#define F(i,j,n) for(int i=j;i<=n;i++)
#define maxn 1000100
char s[maxn],p[maxn];
int nxt[maxn],ls,lp,t,ans;
inline void getnext()
{
int i=0,j=-1;
nxt[0]=-1;
while (i!=lp)
{
if (j==-1||p[i]==p[j]) nxt[++i]=++j;
else j=nxt[j];
}
}
inline void kmp()
{
int i=0,j=0;ans=0;
while (i!=ls)
{
if (s[i]==p[j]||j==-1) ++i,++j;
else j=nxt[j];
if (j==lp)
{
ans++;
j=nxt[j];
}
}
}
int main()
{
scanf("%d",&t);
while (t--)
{
scanf("%s%s",p,s);
ls=strlen(s);lp=strlen(p);
getnext();
kmp();
printf("%d\n",ans);
}
return 0;
}
顶 0 踩 0
我的同类文章
猜你在找
查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
个人资料
AaronGZK
积分:1501
联系方式
QQ:1045980567
Email:guozhongkang@hotmail.com
友情链接
Elemmir
fqqq
Gvolv
Hist!
Regina8023
Ryan
Vkrms
wjyi
ZYF-ZYF
文章搜索
博客专栏
OIer的狂欢
文章:41篇
阅读:15233文章分类
文章存档