Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16647 Accepted Submission(s): 7037
Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
3 5 5 2 4 3 3 3
Sample Output
1 2 1 3 -1
Author
hhanger@zju
Source
题意:一块h*w的广告板上贴广告,每条广告均为1*wi;如果能贴,输出贴的位置(即第几行,位置尽量靠上,靠左);否则输出-1.
分析:首先,叶子节点只有min(n, h)个,不要被10^9吓到;然后把每行的空间存进树,每贴一条广告就删除相应的空间。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 200010
struct node
{
int a,b,r;
}t[MAXN*4];
int h,w,n;
void build(int x, int y, int num)
{
t[num].a = x;
t[num].b = y;
t[num].r = w;
if(x == y) return ;
int mid = (x+y)>>1;
build(x, mid, num<<1);
build(mid+1, y, num<<1|1);
}
int query(int x, int num)
{
if(t[num].a == t[num].b)
{
t[num].r -= x;
return t[num].a;
}
else
{
int sum1=0, sum2=0;
if(x <= t[num<<1].r) sum1 = query(x, num<<1);
else if(x <= t[num<<1|1].r) sum2 = query(x, num<<1|1);
t[num].r = max(t[num<<1].r, t[num<<1|1].r);
return sum1+sum2;
}
}
int main()
{
while(scanf("%d%d%d",&h,&w,&n)==3)
{
if(h > n) h = n;
build(1, h, 1);
int k;
for(int i=1; i<=n; i++)
{
scanf("%d",&k);
if(k <= t[1].r) printf("%d\n",query(k, 1));
else printf("-1\n");
}
}
return 0;
}
顶 0 踩 0
我的同类文章
猜你在找
查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
个人资料
d_x_d
积分:1362
文章搜索
博客专栏
各OJ刷题专栏
文章:57篇
阅读:24590